Possible New registration failures
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with possible new account registration failures. New account registrations should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Apr 01, 2020 - 10:35 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with possible new account registration failures from past few hours and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Apr 01, 2020 - 09:42 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).