Email Deliverability Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with emails being sent. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 21 days ago. Jan 29, 2019 - 20:36 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issues with sending emails via the DigitalOcean control panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 21 days ago. Jan 29, 2019 - 18:53 UTC
Investigating
Our engineering team is investigating issues with emails being sent via the DigitalOcean control panel. At this time, emails for device verification, referrals, and team invites are not being correctly sent out. We apologize for the inconvenience and will share an update once we have more information.
Posted 21 days ago. Jan 29, 2019 - 17:48 UTC