Issues with Support Portal for Users Who Have Recently Signed Up
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with our support portal. Support ticketing should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jan 30, 2020 - 04:31 UTC
Monitoring
Our engineers have implemented a fix to resolve the issue with our support portal ticketing and are monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Jan 30, 2020 - 03:45 UTC
Identified
Our engineering team has identified the cause of the issue and is actively working on a fix. We will post an update as soon as additional information is available.
Posted Jan 29, 2020 - 17:30 UTC
Investigating
Our engineering team is investigating an issue with support ticket routing, and our support portal. At this time, users who have recently signed up with DigitalOcean may experience an error when attempting to access the support portal or submit tickets at https://cloudsupport.digitalocean.com/s/. Existing users should not be affected, and may continue to use the support portal normally.

To work around any issues with the support portal, users may submit tickets via our contact form here: https://www.digitalocean.com/company/contact/#support

We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 29, 2020 - 16:50 UTC
This incident affected: Regions (Global) and Services (Support Center).