Customer Support Ticket Portal
Incident Report for DigitalOcean
Resolved
Our team has confirmed the issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com/s/ is fully resolved. We sincerely apologize and thank you for your patience as we worked through this issue.

In case of any questions or concerns, please open a ticket with our Support team.
Posted Mar 06, 2023 - 19:53 UTC
Monitoring
Our Engineering team has implemented a fix to correct the intermittent errors with the Support Portal and is monitoring the situation. We are working with our vendor to ensure future stability and will post an update once we can confirm full resolution.
Posted Mar 04, 2023 - 03:03 UTC
Identified
Our Engineering team has identified the cause of the issues causing intermittent errors with the Support Portal and is currently working with our vendor on a fix. We will provide an update as soon as the changes are fully implemented.

As this issue is intermittent, users may occasionally still see errors when trying to reach support. As a temporary workaround users can still contact us via the form here:
https://www.digitalocean.com/company/contact/support
Posted Mar 04, 2023 - 01:31 UTC
Investigating
Our Engineering team has observed a recurrence of this incident that intermittently continues to impact our Support portal at https://cloudsupport.digitalocean.com/. We are aware of these events and are working with our vendor to permanently resolve the issue.

As this issue appears to be intermittent, users may occasionally see errors when trying to connect to the Support portal. As a temporary workaround users can still contact us via the form here:
https://www.digitalocean.com/company/contact/support

We will post an update as soon as further information becomes available. Thank you for your patience and we apologize for the inconvenience.
Posted Mar 02, 2023 - 16:38 UTC
Update
Our Engineering team has made additional changes to our Support Portal, We've confirmed that logging in to the portal is working correctly at this time. We're continuing to monitor and work with our vendor to fully resolve this incident.

If you experience any issues with the Support Portal, please continue to use the form here: https://www.digitalocean.com/company/contact/support
Posted Mar 01, 2023 - 15:47 UTC
Update
Our Engineering team has observed recurrences of this incident and we are in communication with our vendor to find a permanent solution. Some users may continue to experience issues on an intermittent basis while logging into our Support portal at https://cloudsupport.digitalocean.com/. As a temporary workaround, users may still contact us via the form here:
https://www.digitalocean.com/company/contact/support

We appreciate your patience and understanding in this process and will keep you posted with further updates in the due course.
Posted Feb 28, 2023 - 20:06 UTC
Update
Our Engineering team has observed recurring instances of this incident that intermittently continue to impact our Support portal at https://cloudsupport.digitalocean.com/. We are aware of these events and our engineers are working with our vendor to resolve this.

As this issue is intermittent, we expect users will be able to log support tickets normally. However, during any periods of unavailability, as a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as further information becomes available.
Posted Feb 27, 2023 - 15:49 UTC
Update
As of 01:32 UTC, our Engineering team has observed the reoccurrence of the login issue with our Support Portal and identified that during this time a subset of users may still observe an "Oops, Something Went Wrong" error on the page. As a temporary workaround, users can still contact us via the form here: https://www.digitalocean.com/company/contact/support

Our Engineering team is actively working on fixing the issue with Customer Support Ticket Portal. We apologize for the inconvenience and will post an update as soon as the issue is fully resolved.
Posted Feb 27, 2023 - 06:00 UTC
Monitoring
Our engineering team has implemented a fix to resolve the login issue with our Support Portal and is monitoring the situation.

Customers should now be able to login and create tickets using our Support Portal at https://cloudsupport.digitalocean.com.

We will post an update as soon as the issue is fully resolved.
Posted Feb 26, 2023 - 22:17 UTC
Investigating
Our Engineering team is investigating an issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com.

At this time, a subset of users may observe an "Oops, Something Went Wrong" error on the page. As a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

We apologize for the inconvenience and will post an update as soon as further information is available.
Posted Feb 26, 2023 - 18:29 UTC
This incident affected: Regions (Global) and Services (Support Center).