Managed Kubernetes Dashboard
Incident Report for DigitalOcean
Resolved
Between 9:50 - 13:00 UTC, users were unable to load the Managed Kubernetes page in the Cloud Panel. Our Engineering team has fully resolved this issue and all services are functioning correctly.

If you continue to experience problems, please open a ticket with our support team. We apologise for any inconvenience.
Posted Aug 19, 2022 - 14:28 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with functionality of the Managed Kubernetes page in the Cloud Panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Aug 19, 2022 - 13:16 UTC
Investigating
Our Engineering team is investigating an issue with the functionality of the Managed Kubernetes page in the Cloud Panel. During this time, users will experience a white page while accessing the Kubernetes dashboard. Cluster functionality remains unaffected and users may utilize the API to manage their clusters. We apologize for the inconvenience and will share an update once we have more information.
Posted Aug 19, 2022 - 13:05 UTC
This incident affected: Regions (Global) and Services (Kubernetes).