New Account Creations
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue impacting new account creations, which should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Nov 13, 2021 - 15:22 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue impacting new account creations and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Nov 13, 2021 - 14:03 UTC
Investigating
Our engineering team is currently investigating an issue impacting new account creations with email sign-ups that stopped working at 2021-11-12 22:50:33 UTC. During this time, new users may experience difficulty with completing the email sign-up process. For users with Google or GitHub accounts, signing up with those authentication methods continues working. We apologize for the inconvenience and will share an update once we have additional information.
Posted Nov 13, 2021 - 13:34 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).