Payments via Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our Engineering team has successfully resolved the issue with Payments on Cloud Control Panel and the service should now be functioning normally. Thank you for your patience, and if you continue to experience problems, please open a ticket with our support team.
Posted Jun 30, 2022 - 06:33 UTC
Monitoring
Our Engineering team is Monitoring the deployed fix for the issue with Payments on the Cloud Control Panel. As of 04:56 UTC, users should no longer experience timeouts/failures when submitting Payments. We will post an update once we confirm this incident is fully resolved.
Posted Jun 30, 2022 - 05:27 UTC
Identified
Our Engineering team has identified the issue that was affecting payments on the Cloud Control Panel and has implemented a fix. We are currently assessing the impact and will post an update once we have more information.
Posted Jun 30, 2022 - 05:13 UTC
Investigating
As of 04:00 UTC, our Engineering team is investigating an issue with payments using third-party provider. During this time, you may experience timeouts/failures when trying to submit payments. We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 30, 2022 - 04:15 UTC
This incident affected: Regions (Global) and Services (Billing).