Issues processing PayPal payments.
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with PayPal payments. Payment processing should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 10 days ago. Sep 10, 2019 - 05:24 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with PayPal payments and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 10 days ago. Sep 10, 2019 - 04:52 UTC
Update
Our Engineering team identified an issue with PayPal payments. During this time, you may experience payment processing errors. We apologize for the inconvenience and will share an update once we have more information.
Posted 10 days ago. Sep 10, 2019 - 04:35 UTC
Investigating
Our engineering team is investigating an issue with PayPal payments. During this time, you may experience payment processing errors. We apologize for the inconvenience and will share an update once we have more information.
Posted 10 days ago. Sep 10, 2019 - 03:46 UTC
This incident affected: Regions (Global).