Multiple Products Down
Incident Report for DigitalOcean
Resolved
Our Engineering team has completely resolved the issues that caused an impact on multiple products, and all services should now be operating normally. Thank you for your patience throughout this process. If you continue to experience problems, then please open a ticket with our support team.
Posted Mar 27, 2022 - 20:36 UTC
Monitoring
Our Engineering team has implemented a fix for the issues that caused an impact on multiple products. We are continuing to monitor the situation closely as the functionality of the services recovers. We apologize for the inconvenience and will share another update once the matter is fully resolved.
Posted Mar 27, 2022 - 19:53 UTC
Investigating
Our Engineering team is currently investigating an issue impacting multiple products on our platform. During this time, users may experience errors when interacting with Cloud Control Panel, API, and some components on our Community platform. Users may see connectivity issues with their Droplets in the NYC1 region as well. Users may also face errors when creating new Snapshot and Backup Images in NYC1, or transferring images to/from the NYC1 region. Our engineers are investigating the impact and we will post further updates as we gather more information. We apologize for any inconvenience.
Posted Mar 27, 2022 - 19:25 UTC
This incident affected: Services (API, Cloud Control Panel, Monitoring, Networking) and Regions (Global).