Issues with Creation of Droplets and Other Services
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with Droplet creation. Creation events should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Sep 02, 2020 - 00:57 UTC
Monitoring
Our engineers have implemented a fix to resolve the issue with Droplets and other resource creation and are monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Sep 02, 2020 - 00:05 UTC
Identified
Our Engineering team has investigated and identified an issue with Droplet and other resource creation, such as Managed Kubernetes Clusters and Load Balancers, etc. At this time, users may see issues with creating resources, including slow creation and eventual timeouts. Our team is actively working on a fix and we will post an update as soon as additional information is available.
Posted Sep 01, 2020 - 20:56 UTC
This incident affected: Regions (Global) and Services (Droplets, Kubernetes, Load Balancers, Managed Databases).