Email issues with support@digitalocean.com address
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with opening support tickets via support@digitalocean.com and it should now be operating normally. Tickets emailed to us while the issue occurred were delayed but have been received normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 7 months ago. Jan 17, 2019 - 22:26 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issues with opening support tickets via support@digitalocean.com and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 7 months ago. Jan 17, 2019 - 21:55 UTC
Investigating
Our engineering team is investigating issues with opening support tickets via support@digitalocean.com. We apologize for the inconvenience and will share an update once we have more information. During this time, tickets can still be created via customer portal.
Posted 7 months ago. Jan 17, 2019 - 21:17 UTC
This incident affected: Regions (Global) and Services (Support Center).