DigitalOcean Services Status

Droplet Creation in BLR1
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed full resolution of DNS resolution issue in the BLR1 region.

We appreciate your patience throughout this process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted Mar 15, 2024 - 23:54 UTC
Monitoring
Our Engineering team has rolled out a fix for the DNS resolution issue in the BLR1 region. Users should now be able to create Droplets with firewall rules.

We'll post an update once the incident is fully resolved.
Posted Mar 15, 2024 - 23:27 UTC
Investigating
Our Engineering team is currently investigating issues with DNS resolution in BLR1 region. During this time, customers may experience issues while creating new Droplets with firewall rules in the BLR1 region.

We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 15, 2024 - 23:09 UTC
This incident affected: Droplets (BLR1) and DNS.