DigitalOcean Services Status

Droplet creates, Snapshots, and Backups
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the complete resolution of the issue with the creation of Droplets, Snapshots, and Backup in our NYC1, NYC3, AMS3, and SFO3 regions.

Thank you for your patience. If you continue to experience any problems, please open a support ticket from within your account.
Posted Mar 21, 2024 - 17:13 UTC
Monitoring
Our Engineering team identified the root cause and performed a service rollback to resolve the issue that was causing high error rates for the creation of Droplets, Snapshots, and Backups in our NYC1, NYC3, AMS3, and SFO3 regions. We are actively monitoring the situation to ensure stability and will provide an update once the incident has been fully resolved.

Thank you for your patience and we apologize for the inconvenience.
Posted Mar 21, 2024 - 16:47 UTC
Investigating
Our Engineering team is investigating an issue with Droplet creates, Snapshots, and Backups in our NYC1, NYC3, AMS3, and SFO3 regions. During this period, customers might experience errors when creating Droplets, taking Snapshots, and/or scheduled Backups might fail to generate.

We will post an update as soon as additional information is available.
Posted Mar 21, 2024 - 16:36 UTC
This incident affected: Event Processing (AMS3, NYC1, NYC3, SFO3).