DigitalOcean Services Status

DBaaS Cluster Logs

Incident Report for DigitalOcean

Resolved

Our Engineering team has successfully resolved the issue that was impacting the DBaaS cluster logs. API responses should be successful without any error messages while retrieving logs, and the "Recent Logs" section is also working as expected.

We have continued to monitor the system and have observed stable performance. The issue is now fully resolved.

Thank you for your patience while we worked to address the issue. If you are still facing issues, please open a ticket from within your Cloud Control Panel for further review.
Posted Jun 03, 2025 - 19:20 UTC

Monitoring

Our Engineering team has now mitigated the issue that affected the DBaaS cluster logs and is currently being monitored. Users should no longer see 500 errors when attempting to retrieve the logs via the API. The "Recent Logs" section in the Logs & Queries tab of the UI should now display logs as expected.

We are continuing to monitor the situation closely to ensure stability. Thank you for your patience during the process and we will provide a final update once we confirm the issue is fully resolved.
Posted Jun 03, 2025 - 18:29 UTC

Investigating

Our Engineering team is currently investigating an issue with fetching DBaaS cluster logs, affecting all non-MongoDB clusters.

Affected users may encounter 500 errors when attempting to retrieve logs via the API, and no logs will appear in the Recent Logs tab.

We apologize for the inconvenience and will provide updates as soon as we have more information. Thank you for your patience.
Posted Jun 03, 2025 - 16:26 UTC
This incident affected: Managed Databases (Global).