Significant submarine cable outages continue to impact multiple network carriers on the Indian subcontinent, with increased latency and packet loss to our BLR1 region occurring sporadically throughout the day.
On a positive note, our upstream providers have worked diligently over the past couple of days to minimize the impact of the loss of submarine capacity. As a result, we are now mainly seeing service degradation during the busier evening peak hours only.
For the moment, we have no updates to provide regarding when the situation might improve. Repair times for submarine cables are typically on the order of weeks or months. However, further short-term improvements may still be possible as upstream carriers work to re-balance traffic where feasible.
Separately, we continue to look into potential avenues for additional mitigations and will keep our customers aprised as we make progress in this area.
We apologize for the ongoing inconvenience created by this extraordinary situation and thank our customers for their patience.
Posted Sep 08, 2025 - 22:29 UTC
Monitoring
Our Engineering team confirms that multiple subsea cable cuts are impacting connectivity in the APAC region, which also affects traffic to Europe and the U.S. East Coast.
Traffic is being rerouted through alternate paths to maintain service continuity. As a result, users may experience higher latency and intermittent connectivity issues.
Our engineering team continues to monitor the situation closely and is working with upstream providers as repair efforts progress. We will share further updates as they become available.
We apologize for the disruption and appreciate your patience.
Posted Sep 06, 2025 - 23:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 06, 2025 - 18:49 UTC
Update
Our Engineering team has implemented changes to optimize traffic routing in the BLR and SGP regions, addressing networking issues stemming from our upstream providers, which are affected by major submarine cable outages in the APAC region. Despite these adjustments, users may still encounter intermittent packet loss or connectivity issues when accessing resources in the affected areas. We are working with our upstream vendors to gain further insights and achieve a definitive resolution.
We apologize for any inconvenience caused.
Posted Sep 06, 2025 - 18:44 UTC
Identified
Our Engineering team has identified the cause of the issue impacting networking connectivity in BLR1 region to be with our upstream provider.
Our team is actively working on remediation steps. We will post an update as soon as we have more information.
Posted Sep 06, 2025 - 16:48 UTC
Investigating
Our Engineering team is currently investigating an issue impacting networking in BLR1 region. Users may experience network connectivity loss to Droplets and Droplet-based services, like Managed Kubernetes and Database Clusters.
We apologize for the inconvenience and will share an update once we have more information.