Subset of Unresponsive Droplets
Incident Report for DigitalOcean
Resolved
Our engineering team has successfully resolved the issues affecting a subset of our Droplets. Networking connectivity and all Droplet actions such as resizes should be working correctly now. If you continue experiencing any issues, please open a support ticket so that we can better assist you.
Posted Jun 10, 2021 - 00:08 UTC
Monitoring
Our engineering team has applied a fix for the subset of Droplets that were experiencing issues across all regions. We're now monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Jun 09, 2021 - 22:30 UTC
Update
Our Engineering team continues to work towards a fix for the issue impacting a subset of Droplets across all regions. Much progress has been made towards mitigating the impact of this issue, but our Engineers are still working towards a permanent solution. During this time, affected Droplets might encounter issues responding to network requests, and Droplet actions such as resizes, rebuilds, etc might fail.

Our Engineering team also identified that this could impact Droplet-backed products such as Managed Kubernetes and Managed Databases, as well. In terms of impact to Managed Kubernetes, some nodes in some clusters will be affected by this issue, but not all nodes in all clusters. There should not be any impact to the management of Managed Kubernetes clusters (create/delete, scale, resize, etc).

We understand that this has been a long process and your continued patience is greatly appreciated. We will share more information as it becomes available.
Posted Jun 09, 2021 - 17:25 UTC
Update
Our Engineering team has identified a recurring issue affecting a subset of Droplets. During this time, affected Droplets might not be responding to network requests, and Droplet actions such as resizes, rebuilds etc. might fail. Our Engineering team also identified that it could affect Droplet-backed products such as Managed Kubernetes as well. We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 09, 2021 - 11:11 UTC
Identified
Our Engineering team has identified a recurring issue affecting a subset of Droplets. During this time, affected Droplets might not be responding to network requests, and Droplet actions such as resizes, rebuilds etc. might fail. We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 09, 2021 - 08:46 UTC
Update
Our Engineering team has implemented a fix regarding the issue impacting Subset of Droplets. Affected Droplets are now reachable and users are able to perform actions such resize, rebuilds etc. We're now monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Jun 09, 2021 - 07:03 UTC
Investigating
Our Engineering team is currently investigating an issue globally impacting a subset of Droplets. At this time, users may experience being unable to reach their Droplet via network requests and see errors or stuck events when attempting Droplet actions such as resizes, rebuilds, etc. Our team is currently working to identify which regions are most impacted, as well as what specific Droplets are impacted. We realize how impacting this is and will provide an update as soon as possible. Thank you for your patience.
Posted Jun 09, 2021 - 01:46 UTC
This incident affected: Regions (Global) and Services (Droplets, Event Processing).