As of 23:00 UTC, our Engineering team has confirmed that the issue causing delays in App Platform deployments has been fully resolved. The fix implemented earlier has been successful, and we are no longer seeing any delays or errors with deployments.
Users should now be able to deploy their apps successfully and without any issues. We apologize again for the inconvenience caused.
However, if you continue to experience any issues, please don't hesitate to raise a support ticket for further investigation.
Posted Mar 14, 2026 - 01:47 UTC
Monitoring
After working with our upstream provider, our Engineering team has implemented a fix to resolve the issue that was causing delays in the deployment of new apps, and they are currently monitoring the situation.
During this time, users should no longer experience issues with creating new apps and all the stalled creation events should provision completely.
We will post an update as soon as the issue is fully resolved.
Posted Mar 13, 2026 - 23:39 UTC
Identified
Our Engineering team is starting to see delays once again with new App Platform deployments. During this time, users may still experience delays with deploying new apps. We're working with our upstream provider to resolve the issue.
We again apologize for the inconvenience. We will post further updates once we have more information.
Posted Mar 13, 2026 - 22:01 UTC
Monitoring
Starting at 20:40 UTC, users may have seen delays with deploying new apps on App Platform.
At this time, our Engineering team is seeing signs of recovery, and users should be able to deploy new apps without issue. We're currently monitoring the situation to ensure full recovery.
We apologize for the inconvenience. We'll post an update once the issue has been confirmed to be resolved.