Droplet Creation Delays.
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with Droplet creation delays. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Feb 15, 2020 - 02:05 UTC
Monitoring
Our Engineering team has implemented a fix for the Droplet creation delays, and functionality should be fully restored at this time. Our team is now monitoring the situation for any further issues. We apologize for the inconvenience and will share an update once we have confirmed that the issue is resolved.
Posted Feb 15, 2020 - 01:18 UTC
Identified
Our engineering team has identified the cause of Droplet creation delays in all regions and is actively working on a fix. During this time, you may experience a delay when creating Droplets in the control panel or via the API. We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 14, 2020 - 23:48 UTC
This incident affected: Regions (Global).