DigitalOcean Services Status

Subsea Fiber Faults
Incident Report for DigitalOcean
Resolved
Our Engineering team has observed stability for network routes and App Platform builds and deployments over the last week. Given this, we will proceed with closing out this incident.

If the situation changes or we receive any important updates regarding the repair of the fiber faults, we will communicate as needed.

If you are still experiencing any issues or have any questions, please feel free to open a support ticket from within your account. Thank you for your patience.
Posted Sep 12, 2023 - 15:41 UTC
Monitoring
Our Engineering team has observed some improvement in the networking routes between NYC and the Western EU, including FRA, AMS, and LON.

Due to the general nature of internet outages, DigitalOcean users may still experience degraded network performance in the form of increased latency and/or packet loss on these routes for Droplets, Droplet-based services, and App Platform builds and deployments.

We’ll continue to monitor the situation through the next few days and provide any needed updates. If you experience any issues, feel free to open a support ticket and our team will be happy to assist. (edited)
Posted Sep 02, 2023 - 04:32 UTC
Update
Our Engineering team will continue to monitor the upstream issue impacting networking routes between NYC and the Western EU, including FRA, AMS, and LON.

DigitalOcean users may experience degraded network performance in the form of increased latency and/or packet loss on these routes for Droplets and Droplet-based services. Additionally, we've identified this issue is impacting App Platform builds and deployments, leading to latency or failures.

We do not have a firm ETA for resolution time but will provide updates on repairs as they are made available to us.
Posted Aug 31, 2023 - 06:41 UTC
Identified
Our Engineering team is aware of an upstream issue impacting networking routes between NYC and the Western EU, including FRA, AMS, and LON.

Despite routing path changes made, DigitalOcean services continue to see impact. The issues are a direct result of subsea fiber faults, which are in the process of being repaired.

DigitalOcean users may experience degraded network performance in the form of increased latency and/or packet loss on these routes for Droplets and Droplet-based services.

Additionally, we've identified this issue is impacting App Platform builds and deployments, leading to latency or failures.

We do not have a firm ETA for resolution time but we will provide updates as needed.
Posted Aug 30, 2023 - 23:27 UTC
This incident affected: Networking (AMS2, AMS3, FRA1, LON1, NYC1, NYC2, NYC3).