DigitalOcean Services Status

Managed Database Operations
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the full resolution of the issue impacting Managed Database Operations, and all systems are now operating normally. Users may safely resume operations, including upgrades, resizes, forking, and ad-hoc maintenance patches.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Dec 13, 2024 - 04:05 UTC
Monitoring
Our Engineering team has implemented a fix for the issue impacting Managed Database Operations. The team is monitoring the situation, and we will share an update once this is fully resolved.
Posted Dec 13, 2024 - 03:13 UTC
Update
Our Engineering team is continuing to work on investigating the root cause of the issue affecting Managed Database Operations. At this time, we are seeing improvement and some new cluster creations are completing successfully.

To avoid potential downtime, we continue to ask users to refrain from performing operations that trigger node rotations, such as upgrades, resizes, forking, and ad-hoc maintenance patches.

We apologize for any inconvenience caused and appreciate your patience. We will post further updates as soon we have more information.
Posted Dec 12, 2024 - 22:03 UTC
Update
During our investigation, we identified that operations triggering node rotation, such as upgrades, resizes, forking and ad-hoc maintenance patches, may cause issues connecting to the cluster.

To prevent potential downtime, we recommend avoiding these operations until the issue is fully resolved.

We apologize for the inconvenience and appreciate your patience as we work to address the situation.
Posted Dec 12, 2024 - 19:35 UTC
Investigating
Our Engineering team is investigating an issue with the Managed Database clusters which is causing forks, restores and new creates to fail. The Mongo clusters are unaffected and should be operating normally.

Our team is currently assessing the root cause and working to resolve the issue as quickly as possible.

We apologize for any inconvenience this may cause and will share an update as soon as we have more information.
Posted Dec 12, 2024 - 18:34 UTC
This incident affected: Managed Databases (Global).