DigitalOcean Services Status

Settings in Cloud Control Panel Unavailable
Incident Report for DigitalOcean
Resolved
From approximately 15:00 - 15:35 UTC, users saw a 404 error when navigating to the Settings page in our Cloud Control Panel.

Our Engineering team has confirmed full resolution of the issue.

If you continue to experience issues, please open a Support ticket from within your account.
Posted Jan 04, 2024 - 15:59 UTC
Monitoring
Our Engineering team has identified the root cause of the issue with the Settings portion of our Cloud Control Panel throwing a 404 and has implemented a fix. At this time, users should be able to navigate to the Settings tab or directly to https://cloud.digitalocean.com/account/team normally.

We are monitoring the fix and will post a final update once we confirm full resolution.
Posted Jan 04, 2024 - 15:39 UTC
Investigating
Our Engineering team is investigating an issue with the Settings portion of our Cloud Control Panel. At this time, users navigating to the Settings tab or directly to https://cloud.digitalocean.com/account/team will see a 404 error.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 04, 2024 - 15:24 UTC
This incident affected: Cloud Control Panel.