DigitalOcean Services Status

Managed Kubernetes Cluster Creation
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the full resolution of the issue impacting the Managed Kubernetes cluster creation. As of 12:18 UTC the functionality has been restored completely and users should be able to deploy new clusters via Cloud Control Panel and API.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jun 26, 2024 - 14:10 UTC
Monitoring
Our Engineering team has deployed a fix for the issue impacting the Managed Kubernetes cluster creation across all regions. The impact has been mitigated and users should no longer experience any issues deploying new clusters via Cloud Control panel and API.

We are monitoring the situation and will post an update once the incident is completely resolved.
Posted Jun 26, 2024 - 13:36 UTC
Investigating
Our Engineering team is investigating an issue impacting our Managed Kubernetes service in all regions. Beginning 11:10 UTC, users may have experienced errors while creating new clusters using Control panel and API.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 26, 2024 - 12:05 UTC
This incident affected: Kubernetes (AMS3, BLR1, FRA1, LON1, NYC1, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1).