DigitalOcean Services Status

App Platform Deployments

Incident Report for DigitalOcean

Resolved

From 07:19 UTC to 08:15 UTC, users may have experienced errors with app deployment via App Platform.

Our Engineering team has now confirmed the resolution of the issue and app deployment should be working as expected.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted May 22, 2025 - 10:59 UTC

Investigating

As of 07:19 UTC, our Engineering team is currently investigating an issue causing delays in the creation of apps deployed via App Platform. During this time, some users may see app deployment failing to complete.

We are actively working on identifying the root cause of issues and will post further updates as more information is available. We apologize for the inconvenience.
Posted May 22, 2025 - 08:35 UTC
This incident affected: App Platform (Global).