DigitalOcean Services Status

Kubernetes Deployments in NYC1

Incident Report for DigitalOcean

Monitoring

The issue affecting Kubernetes deployments in NYC1 has subsided. Workloads should now be functioning normally.

Our Engineering team is continuing to monitor the affected systems to confirm full resolution. We'll update this page if any further action is needed. We apologize for the inconvenience this may have caused.
Posted Jul 10, 2026 - 01:18 UTC

Investigating

Our Engineering team is investigating an issue affecting Kubernetes deployments in NYC1. Users may see intermittent DNS failures and NodeNotReady events from application workloads during this time.

We apologize for the inconvenience, we'll share new information on this page as soon as it is available.
Posted Jul 09, 2026 - 20:31 UTC
This incident affects: Kubernetes (NYC1).