Invoice generation delays
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with generation of recent Invoices. You should now be able to view and download October Invoices. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 17 days ago. Nov 01, 2018 - 11:08 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with generation of invoices and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 17 days ago. Nov 01, 2018 - 10:23 UTC
Identified
Our engineering team has identified the cause of the issue with generation of recent Invoices and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 17 days ago. Nov 01, 2018 - 10:05 UTC
Investigating
Our engineering team is investigating an issue with generation of recent Invoices. During this time, you may not find your October Invoice in your billing page. We apologize for the inconvenience and will share an update once we have more information.
Posted 18 days ago. Nov 01, 2018 - 08:29 UTC
This incident affected: Regions (Global).