DigitalOcean Services Status

Account Registration, Droplets, and Related Services

Incident Report for DigitalOcean

Update

Our Engineering team continues to work on implementing and rolling out a fix for the issue affecting multiple services across multiple regions, including new account registration, Droplets, Reserved IPs, Automated Backups and Snapshots, Droplet Autoscale, DOKS clusters, GenAI services, the Droplet console, and Database cluster creation.

Customers may continue to experience the previously reported service disruptions while remediation efforts remain in progress. We will provide another update as soon as more information becomes available.
Posted Aug 08, 2026 - 22:02 UTC

Identified

Our Engineering team has identified the root cause of the issue affecting new account registration, Droplets, Reserved IPs, Snapshots, and DOKS clusters across multiple regions.

Customers may experience the following:

Unable to create new accounts
Unable to create Droplets
Unable to allocate Reserved IPs
Failures with Automated Backups and Snapshots operations
Droplet Autoscale scaling operations not working as expected
DOKS cluster operations failing
GenAI services impacted
Unable to access the Droplet console
Database clusters stuck in a "Creating" state

Our Engineering team is working on implementing a fix and we will provide another update as soon as more information becomes available.
Posted Aug 08, 2026 - 20:02 UTC

Update

Our Engineering team is continuing to investigate reports of an issue affecting new account registration, Reserved IPs, Snapshots, Droplets and Droplet-based services across multiple regions.

During this time, customers may be unable to create new accounts, create Droplets, allocate Reserved IPs, or perform Automated Backups and Snapshots operations. Droplet Autoscale scaling operations and DOKS cluster operations are also affected.

Further investigation has found that GenAI services are also affected due to this issue, customers may also be unable to access the Droplet console, and Database clusters may be stuck in a "Creating" state.

Our Engineering team is actively investigating the issue and we will provide another update as soon as more information becomes available.
Posted Aug 08, 2026 - 19:38 UTC

Investigating

Our Engineering team is currently investigating reports of an issue affecting new account registration, Reserved IPs, Snapshots, Droplets and Droplet-based services across multiple regions.

During this time, customers may be unable to create new accounts, create Droplets, allocate Reserved IPs, or perform Automated Backups and Snapshots operations. Droplet Autoscale scaling operations and DOKS cluster operations are also affected.

Our Engineering team is actively investigating the issue and we will provide another update as soon as more information becomes available.
Posted Aug 08, 2026 - 18:57 UTC
This incident affects: Droplets (Global), Managed Databases (Global), Kubernetes (Global), and Reserved IP.