DigitalOcean Services Status

Snapshots are failing in SFO3 and NYC3
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with snapshots taken by customers in the NYC3 and SFO3 regions. If you continue to experience problems, please open a ticket with our support team. Thank you for your patience and we apologize for any inconvenience.
Posted Jan 25, 2024 - 02:56 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with snapshots taken by customers in the NYC3 and SFO3 regions and are monitoring the situation closely.

We will post another update once we're confident that the issue is fully resolved.
Posted Jan 25, 2024 - 01:50 UTC
Identified
Our Engineering team has identified an issue with snapshots taken by customers in the NYC3 and SFO3 regions and is actively working on a fix. We will post an update as soon as additional information is available.
Posted Jan 25, 2024 - 00:26 UTC
This incident affected: Cloud Control Panel and Droplets (NYC3, SFO3).