Our Engineering team has implemented a fix for the issue that was preventing users from submitting or viewing tickets through our Support Ticket Portal. At this time, all users should be able to access the portal and manage tickets normally via https://cloudsupport.digitalocean.com/s/.
Additionally, any previously submitted tickets that were affected by this issue have now been successfully routed to our Support Team, who will be addressing them as quickly as possible.
We sincerely apologize for the inconvenience and appreciate your patience while we worked to resolve this issue.
Posted Jul 30, 2025 - 02:04 UTC
Identified
Our Engineering team has identified the root cause of the issue affecting the ability to submit or view tickets through our Support Ticket Portal. They are actively working on implementing a fix.
We will share another update as soon as more information becomes available. Thank you for your continued patience and understanding as we work to resolve this issue.
Posted Jul 30, 2025 - 01:42 UTC
Investigating
Our Engineering team is investigating an issue with our DigitalOcean Support Ticket Portal. At this time, users may not be able to submit new tickets or view currently opened tickets at https://cloudsupport.digitalocean.com/s/.
We apologize for the inconvenience and will share an update once we have more information.