DigitalOcean Services Status

Droplet Creation

Incident Report for DigitalOcean

Resolved

Our Engineering team has confirmed full resolution of the issue impacting Droplet creation in all regions. Users can now create Droplets without any issues.

We appreciate your patience while we worked to fix this issue. If you continue to experience any problems, please open a ticket from your account for further investigation.
Posted Aug 26, 2025 - 20:01 UTC

Monitoring

Our Engineering team has identified the reason behind the failed Droplet creates and implemented a fix to resolve the issue. Users should now be able to create Droplets.

We are actively monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Aug 26, 2025 - 19:33 UTC

Investigating

Our Engineering team is currently investigating an issue with Droplet creation in multiple regions. This is only affecting new accounts at this time. Existing users are not impacted.

Users with new accounts may experience an elevated failure rate when attempting to create Droplets during this time.

We apologize for the inconvenience and will share an update once we have more information.
Posted Aug 26, 2025 - 18:30 UTC
This incident affected: Droplets (Global).