From 17:14 UTC to 17:34 UTC, users experienced issues accessing the Cloud Control Panel and API.
Our Engineering team has resolved the issue, and the Cloud Control Panel, API, and events should now be functioning normally.
If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Feb 25, 2025 - 18:28 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue impacting the Cloud Control Panel and API. Users should no longer experience issues with accessing the Cloud Control Panel and API.
We will continue to monitor the situation and post an update once this issue is fully resolved. Thank you for your patience.
Posted Feb 25, 2025 - 17:58 UTC
Identified
Our Engineering team has identified the cause of the issue impacting our Cloud Control Panel and API and is actively working on implementing a fix. We are already seeing signs of recovery, and users should now have access to the Cloud Control Panel and API.
We will post an update as soon as additional information is available.
Posted Feb 25, 2025 - 17:44 UTC
Update
We are continuing to investigate this issue.
Posted Feb 25, 2025 - 17:32 UTC
Investigating
Our Engineering team is investigating an issue impacting our Cloud Control Panel and API.
During this time, users will experience errors when trying to use the public API at api.digitalocean.com or while accessing our Cloud Control Panel at https://cloud.digitalocean.com. Users may also see issues with processing Droplet and Kubernetes cluster creations along with Droplet-based events.
We are now confirming the full impact. We regret any inconvenience and will let you know as soon as more information is available.
Posted Feb 25, 2025 - 17:27 UTC
This incident affected: API, Cloud Control Panel and Event Processing (Global).