Public API Issues
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issues with the Public API and Cloud Control Panel and we have confirmed that these services are operating normally at this time.

If you continue to see any issues with our API or the Networking section of the Cloud Control Panel, please reach out to our Support team.
Posted Feb 05, 2020 - 23:00 UTC
Monitoring
Our Engineering teams believe the root cause of this incident has been mitigated. Our Cloud Operations team continues to monitor these services to ensure we maintain stability.

Once we are confident this issue will not reoccur, we will move this incident to Resolved.

In the meantime, if you continue to see any issues with our API or Cloud Control Panel in the Networking section, please reach out to our Support team.
Posted Feb 05, 2020 - 19:32 UTC
Update
Our Engineering teams are continuing to investigate the root cause of these API and Cloud Control Panel issues. Our Cloud Operations team has been actively mitigating impact while our Engineering teams work on additional telemetry to pinpoint a root cause to these problems.

While our team continues to develop a solution, we believe that the implemented workaround will prevent any continued impact on users. Any recurrence will not affect our API in general – only the DNS API request would see failures alongside the Networking section in our Cloud Control Panel.

Additionally, users may experience delays with processing actions on Managed Kubernetes clusters.

We apologize for any inconvenience this has caused, and we will share another update as more work is done to resolve this issue.
Posted Feb 04, 2020 - 17:59 UTC
Update
Our engineering team has not yet identified the root cause for the issues experienced with the API and Cloud Control Panel, and we are continuing to investigate. However, as of now, impact from the issue has resolved. At this time, users should no longer be experiencing any issues. Until we have fully identified and mitigated the root cause, the issue may reoccur. This may cause users to experience issues with our public API and the Networking section in our Cloud Control Panel, as well as see delays with processing actions on Managed Kubernetes clusters. We apologize for the inconvenience, and we will share another update once we have further information.
Posted Feb 03, 2020 - 18:01 UTC
Update
Our engineering team is continuing to investigate this issue, but we have identified that some aspects of our Cloud Control Panel are also affected by this issue. At this time, users may also experience issues navigating to/interacting with the Networking section in our Cloud Control Panel. We will share an update once we have further information.
Posted Feb 03, 2020 - 17:33 UTC
Investigating
Our engineering team is investigating an issue with our API. During this time, users may experience issues while using the API, including seeing 500 errors being returned when attempting to send requests. We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 03, 2020 - 17:14 UTC
This incident affected: Services (API, Cloud Control Panel, Kubernetes) and Regions (Global).