DigitalOcean Services Status

Droplet Based Events in FRA1

Incident Report for DigitalOcean

Resolved

Our Engineering team has confirmed that the issue impacting our Droplet-based products in the FRA1 region has been completely mitigated. Users should no longer see issues with their Droplets and Droplet-related services.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jan 28, 2026 - 04:27 UTC

Monitoring

Our Engineering team has identified the cause of the issue impacting our Droplet-based products in the FRA1 region and applied a fix. The impact has started to mitigate and users should be able to connect to their Droplets and also start to see events getting processed successfully.

We're now monitoring the fix for stability and will post an update once we are confident it is successful.
Posted Jan 28, 2026 - 04:11 UTC

Investigating

Our Engineering team is currently investigating an issue affecting events in FRA1. During this time, customers may experience delays or errors when creating or deleting Droplets, as well as when using Droplet-based products such as Load Balancers, Kubernetes Clusters, or Databases.

Our teams are actively working to identify the root cause and restore full service as quickly as possible. We apologize for the inconvenience and will provide updates as more information becomes available.
Posted Jan 28, 2026 - 00:45 UTC
This incident affected: Kubernetes (FRA1), Managed Databases (FRA1), Droplets (FRA1), and Load Balancers (FRA1).