DigitalOcean Services Status

Creating Agents with Attached Knowledge Base

Incident Report for DigitalOcean

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 20:15 UTC

Monitoring

All previously reported issues have now been resolved.

Resolved Issues:

- Indexing jobs are now operational and starting as expected.
- Indexing job statuses are updating normally.
- Evaluation runs on new teams are fully operational.
- Knowledge base creation is functioning correctly.
- Linking functions to agents is now operational.

We appreciate your patience while our team worked to resolve these issues. We will continue to monitor the fixes to ensure everything remains stable.
Posted Jul 02, 2025 - 19:50 UTC

Update

Our Engineering team continues to work on a fix for this issue. We will share further updates as soon as they become available. Thank you for your continued patience.
Posted Jul 02, 2025 - 19:19 UTC

Identified

Our Engineering team has identified several issues impacting indexing jobs and knowledge base creation.

At this time, users may experience the following:

- Indexing jobs are currently failing to start. As a result, most teams will be unable to initiate new jobs.
- For teams where jobs do start, they may remain stuck in a "queued" status.
- Knowledge base creation is still failing and may result in an error.

We apologize for the disruption and will provide further updates as we learn more.
Posted Jul 02, 2025 - 17:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 16:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 15:08 UTC

Investigating

Our Engineering team is investigating an issue with creating agents using an attached knowledge base.

At this time, users may experience errors when attempting to create a new agent and specify a knowledge base during the creation process.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 02, 2025 - 14:24 UTC
This incident affected: GenAI Platform.