Our Engineering team has resolved the issue affecting all control plane operations (Create, Read, Update, Delete) for non-MongoDB Managed Database clusters. All services and App Platform deployments with Managed Databases should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jul 02, 2025 - 18:40 UTC
Monitoring
Our Engineering team has deployed a fix to address the issue affecting all control plane operations (Create, Read, Update, Delete) for non-MongoDB Managed Database clusters. Users should now be able to perform standard database operations successfully. App Platform deployments with Managed Databases should also be succeeding now.
We are now monitoring the situation in order to ensure stability and will post an update once the issue is resolved completely.
Posted Jul 02, 2025 - 17:43 UTC
Investigating
Our Engineering team is investigating an issue that is impacting all control plane operations (Create, Read, Update, Delete) for all non-Mongo Managed Database clusters. During this time, users may encounter 401/403 errors when attempting those operations, including provisioning new clusters, listing clusters, etc.
In addition, App Platform deploys with Managed Databases are also affected, which may result in delayed or failed deployments for some applications.
We will provide updates as more information becomes available.
Posted Jul 02, 2025 - 16:59 UTC
This incident affected: App Platform (Global) and Managed Databases (Global).