DigitalOcean Services Status

New User Sign Ups
Incident Report for DigitalOcean
Resolved
From 13:45 - 16:04 UTC, users were unable to sign up for new DigitalOcean accounts at https://cloud.digitalocean.com and existing users were unable to update credit card information within the Cloud Control Panel, due to an issue with a billing verification key. This issue is now fully resolved and users should be able to interact with the Cloud Control Panel normally.

We apologize for the inconvenience and invite users to retry any failed attempts. If you continue to experience issues or have any questions, please reach out to Support from within your account.
Posted Jun 12, 2024 - 16:41 UTC
Monitoring
Our Engineering team has completed implementation of the fix to resolve the issue with new user sign ups and attempts to update credit card details. At this time, services should be functioning as expected. If you were attempting to sign up or change your existing credit card information, please retry.

We're monitoring the situation and will post a final update once we confirm this is fully resolved.
Posted Jun 12, 2024 - 16:07 UTC
Identified
Our Engineering team has identified the root cause of the issue with new user sign ups and is working to implement a fix. During the course of investigation, the team also identified that existing users are unable to update their existing credit card information.

We will post another update once the fix has been implemented.
Posted Jun 12, 2024 - 15:29 UTC
Investigating
Our Engineering team is investigating an issue with users attempting to sign up for new cloud.digitalocean.com accounts. At this time, users attempting to sign up are unable to do so, due to an issue with finalizing credit card information. Existing users are unaffected and should be able to sign in normally.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 12, 2024 - 15:15 UTC
This incident affected: Cloud Control Panel.