DigitalOcean Services Status

Droplet creates in LON1
Incident Report for DigitalOcean
Resolved
From 22:03 September 11 to 00:13 September 12 UTC, users may have experienced failures with creating Droplets in the LON1 region.

Our Engineering team has confirmed resolution of this issue with users now being able to create Droplets in LON1. Thank you for your patience.

If you continue to experience any problems, please open a support ticket from within your account.
Posted Sep 12, 2024 - 00:56 UTC
Monitoring
Our Engineering team has implemented mitigations for the intermittent issues with Droplet creates in LON1. The team is monitoring the situation, and we will share an update once this is fully resolved.
Posted Sep 12, 2024 - 00:23 UTC
Investigating
Our Engineering team is investigating an issue with Droplet creation in LON1. During this time, users may see an elevated failure rate for the creation of Droplets and other Droplet-based products, such as Load Balancers, Managed Databases, or Kubernetes, in LON1.
Posted Sep 11, 2024 - 23:45 UTC
This incident affected: Kubernetes (LON1), Managed Databases (LON1), Droplets (LON1), and Load Balancers (LON1).