DigitalOcean Services Status

Create Failures in NYC3
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the complete resolution of the issue at 03:51 UTC.

Creating Droplets, all Droplet-based services including Kubernetes Clusters, Managed Databases, Load Balancers, and Snapshots are now working as expected in the NYC3 region.

Thank you for being so patient. If you continue to experience any problems, please open a support ticket from within your account.
Posted May 07, 2024 - 04:41 UTC
Monitoring
Our Engineering team has investigated and identified an issue with creating resources in the NYC3 region. Between approximately 03:18 UTC - 03:51 UTC, customers may have experienced errors when creating Droplets and Droplet-based services including Managed Kubernetes, Managed Databases, Load Balancers, and snapshots.

Our team has implemented a fix to restore the ability to create resources and is monitoring the region. We will post an update as soon as the issue is fully resolved.
Posted May 07, 2024 - 04:11 UTC
This incident affected: Kubernetes (NYC3), Managed Databases (NYC3), Droplets (NYC3), Load Balancers (NYC3), and Event Processing (NYC3).