DigitalOcean Services Status

Droplet connectivity and Event processing in multiple regions.
Incident Report for DigitalOcean
Resolved
As of 10:09 UTC, our Engineering team has confirmed the full resolution of the issue impacting Droplet connectivity and Event processing in multiple regions.
Users should no longer see issues with their Droplets and Droplet-related services.
If you continue to experience problems, please open a ticket with our support team. Thank you for your patience throughout this incident.
Posted Mar 12, 2024 - 11:43 UTC
Monitoring
Our Engineering team has confirmed that the issue impacting Droplet connectivity in multiple regions has been mitigated.

At this time, users should no longer see issues when connecting to their Droplet and Droplet-related services.

We will further monitor this incident and will post an update as soon as the issue is fully resolved.
Posted Mar 12, 2024 - 10:07 UTC
Identified
Our Engineering team has identified the cause of the issue impacting Droplet connectivity in multiple regions and applied a fix.

The impact has started to mitigate and users should be able to connect to their Droplets in the affected regions.

We're now monitoring the fix for stability and will post an update once we are confident it is successful.
Posted Mar 12, 2024 - 09:29 UTC
Update
Our Engineering team continues to investigate the issue impacting Droplet connectivity and Event processing in multiple regions.

At this time, users may experience issues when connecting to their Droplet and may notice events appearing to be stuck or delayed when processed against services in this region.

Additionally, users may see issues with Droplet-based services like Managed Databases, and Kubernetes Clusters in the affected regions.

We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 12, 2024 - 08:28 UTC
Investigating
As of 06:20 UTC, our Engineering team is investigating an issue impacting Droplet connectivity and Event processing in multiple regions.

At this time, users may experience issues when connecting to their Droplet. Also, users may notice events appearing to be stuck or delayed when processed against services in this region.

We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 12, 2024 - 07:24 UTC
This incident affected: Droplets (AMS3, BLR1, FRA1, LON1, NYC2, SFO3, SGP1, TOR1).