Errors with Cloud Control Panel Login
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue impacting Cloud Control Panel logins, and all services should now be functioning normally. Please contact our Support team if you encounter any further issues. Thank you for your patience and understanding throughout this process.
Posted Mar 13, 2020 - 17:34 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 13, 2020 - 15:10 UTC
Monitoring
Our engineering team is currently monitoring an issue which affected Cloud Control Panel logins for a brief window of time between 2:35 PM and 2:55 PM UTC. During this window, users may have experienced errors when accessing the Cloud Control Panel. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 13, 2020 - 15:09 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).