DigitalOcean Services Status

Agent Timeouts While Retrieving Data from Knowledge Bases

Incident Report for DigitalOcean

Identified

Our Engineering team has identified the issue causing Agents to experience timeouts while retrieving data from Knowledge Bases.

Please be assured that our Engineering team is actively working on a fix and is treating this issue with high priority.

We sincerely apologise for any inconvenience this may have caused and appreciate your patience and understanding. If you have any further questions, please create a support ticket so that we can investigate your specific case further.
Posted Jul 01, 2026 - 08:39 UTC

Investigating

Our Engineering team is currently investigating an issue where Agents are experiencing timeouts while retrieving data from Knowledge Bases. As a result, affected Agents may fail to retrieve data and return the following error:

"Failed to retrieve data from Knowledge base(s) - timeout"

Please be assured that we are treating this as a high-priority issue and are actively working to mitigate it.

We sincerely apologise for any inconvenience this may have caused and appreciate your patience and understanding. If you have any further questions, please create a support ticket so that we can investigate your specific case further.
Posted Jul 01, 2026 - 06:25 UTC
This incident affects: Agentic Inference Cloud (Agent Runtime, Knowledge Bases).