DigitalOcean Services Status

Networking in BLR1 region

Incident Report for DigitalOcean

Monitoring

The network connectivity issue affecting the BLR1 region, which was caused by a broader internet issue, has been mitigated. Network accessibility in the region has improved, and users should already experience better performance when accessing Droplets and other services. We are closely monitoring the situation to ensure stability.

We appreciate your patience and will provide an update once the issue is fully confirmed as resolved.
Posted Sep 27, 2025 - 19:39 UTC

Investigating

Our Engineering team is still observing intermittent issues impacting network connectivity in the BLR1 region. This stems from a broader Internet issue impacting the BLR1 region. As a result, users may still continue to experience packet loss/latency, timeouts, and related issues with Droplet-based services in this region, including Droplets, LBaaS, Managed Kubernetes, and Managed Database. Our Engineering team is actively investigating the issue.

We will post an update as soon as additional information is available.
Posted Sep 27, 2025 - 14:29 UTC

Monitoring

The network connectivity issue impacting the BLR1 region has been mitigated. Users should no longer experience packet loss/latency, timeouts, and related issues with Droplet-based services in this region, including Droplets, LBaas, Managed Kubernetes, and Managed Database.

We appreciate your patience and will provide an update once the issue is fully confirmed as resolved.
Posted Sep 27, 2025 - 13:58 UTC

Investigating

Our Engineering team is investigating an issue impacting networking connectivity in BLR1 region with upstream provider. Users may experience network connectivity loss to Droplets and Droplet-based services, like Managed Kubernetes and Database Clusters.

We apologize for the inconvenience and will share an update once we have more information.
Posted Sep 27, 2025 - 13:19 UTC
This incident affects: Networking (BLR1).