Our Engineering team has confirmed that the issue impacting Droplets in the NYC3 region has been fully resolved. Users can now perform actions on their Droplets or create new Droplets in this region without any issues.
We appreciate your patience while we worked to resolve this issue. If you continue to experience any problems, please open a support ticket from your account so our team can investigate further.
Posted Jul 04, 2026 - 15:10 UTC
Monitoring
Our Engineering team has implemented a fix to address the issue affecting Droplets in the NYC3 region. The issue, which began at 12:38 UTC, caused disruptions to customers attempting to perform actions on their Droplets in the NYC3 region.
During this time, customers may also have experienced errors when trying to create Droplets in this region.
We are actively monitoring the situation to ensure the fix remains effective and will provide another update once the issue has been fully resolved.
Posted Jul 04, 2026 - 14:42 UTC
This incident affected: Droplets (NYC3) and Event Processing (NYC3).