Droplet Creation Delays
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with Droplet creation delays. If you continue to experience problems, please open a ticket with our support team through the cloud portal. We apologize for any inconvenience.
Posted 5 months ago. Feb 05, 2019 - 16:17 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with Droplet creations and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 5 months ago. Feb 05, 2019 - 15:38 UTC
Investigating
Our engineering team is investigating an issue with creating Droplets. During this time, you may experience delays while creating a new Droplet. We apologize for the inconvenience and will share an update once we have more information.
Posted 5 months ago. Feb 05, 2019 - 14:36 UTC
This incident affected: Regions (Global) and Services (Event Processing).