DigitalOcean Services Status

Managed Database Operations
Incident Report for DigitalOcean
Resolved
As of 12:30 UTC, our Engineering team has resolved the issue impacting CRUD (create, read, update, delete) operations for Managed Database Clusters in all the regions.

Everything should now be functioning normally. We appreciate your patience throughout the process.

If you continue to experience problems, please open a ticket with our support team.
Posted Jan 09, 2024 - 12:55 UTC
Monitoring
Our Engineering team has confirmed that the action taken to mitigate the recurrence of the issue is successful. Users should no longer experience errors in CRUD (create, read, update, delete) operations for Managed Database Clusters in all regions, via both the Cloud Control Panel and API requests.

We are actively monitoring the situation to ensure stability and will provide an update once the incident has been fully resolved.
Posted Jan 09, 2024 - 10:17 UTC
Identified
Our Engineering team has observed recurrences of the issue with CRUD (create, read, update, delete) operations for Managed Database Clusters in all regions and is actively working on a fix.

During this time, users may experience errors in those operations, via both the Cloud Control Panel and API requests. Mongo clusters remain unaffected, and customers can continue to connect to their existing databases.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 09, 2024 - 09:23 UTC
Monitoring
Our Engineering team has identified the root cause of the issue with CRUD (create, read, update, delete) operations for Managed Database Clusters in all regions, and is seeing error rates drop. We are monitoring the situation and will post an update once we confirm this incident is fully resolved. Mongo clusters remain unaffected, and customers can continue to connect to their existing databases
Posted Jan 09, 2024 - 02:04 UTC
Investigating
As of 00:15, our Engineering team is seeing an increased error rate on CRUD (create, read, update, delete) operations for Managed Database Clusters in all regions, excluding Mongo clusters. During this time, users may experience errors in those operations, via both the Cloud Control Panel and API requests. Also, connectivity for existing clusters is fine.
We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 09, 2024 - 01:35 UTC
This incident affected: Managed Databases (AMS3, BLR1, FRA1, LON1, NYC1, NYC2, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1).