DigitalOcean Services Status

Support Contact Form
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed full resolution of the issue with contact form submissions. From 14:59 - 19:27 UTC, submissions from https://www.digitalocean.com/company/contact were not being routed to our Support teams. All submissions have been routed to our teams and are being addressed.

If you continue to experience problems, please reach out to our support team. Thank you for your patience throughout this incident!
Posted Dec 04, 2023 - 20:32 UTC
Monitoring
Our Engineering team has completed the fix to resolve the issue with submissions from our Support Contact form and at this time, services should be functioning as expected.

Our Support team is addressing all submissions as quickly as possible. We're monitoring the fix and will post an update as soon as we confirm this incident is fully resolved.
Posted Dec 04, 2023 - 20:21 UTC
Identified
Our Engineering team has identified the root cause of the issue with submissions from our Support Contact Form and backlogged submissions are now flowing into our Support queues to be addressed.

If you submitted this form beginning 14:59 UTC to now, we did receive your submission, but it was not routed correctly. Our Support team is now working to address the backlog of submissions as quickly as possible.
Posted Dec 04, 2023 - 19:34 UTC
Investigating
Our Engineering team is currently investigating an issue with our Support Contact Form, which users use when they are unable to log into their accounts to submit support tickets, located here: https://www.digitalocean.com/company/contact/support

At this time, users are still able to submit the form, but the submissions are not being received by our Support Team.

We have confirmed the submissions were received by our systems and we're working to get these submissions over to our Support Team, as well as remediate the issue.

If you are able to log into your account, please submit any Support tickets via https://cloudsupport.digitalocean.com/s/ rather than the contact form.

We will post another update as soon as we have further information. In the meantime, we appreciate your patience as we work through this.
Posted Dec 04, 2023 - 19:12 UTC
This incident affected: Support Center.