DigitalOcean Services Status

Spaces Page in Control Panel
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed resolution of the issue impacting display of Spaces page in Cloud control panel.

From 17:35 UTC to 18:00 UTC, users were experiencing errors when accessing Spaces page in the Cloud Control Panel.

We apologize for the inconvenience. If you have any questions or continue to experience issues, please reach out via a Support ticket on your account.
Posted Oct 15, 2024 - 18:44 UTC
Monitoring
Our Engineering team has successfully deployed a fix for the display issue with Spaces Object Storage in the Cloud control panel. Some users may have experienced 400 errors or difficulties accessing the page when using Spaces through the Cloud Control Panel.

We are currently monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Oct 15, 2024 - 18:25 UTC
Identified
Our Engineering team has identified a display issues with Spaces Object Storage in the Cloud control panel and a fix is currently being deployed. During this time, some users may see 400 errors or be unable to access the page when accessing Spaces through the Cloud Control Panel.

We apologize for the inconvenience and will share an update once the fix has finished deploying.
Posted Oct 15, 2024 - 17:56 UTC
This incident affected: Cloud Control Panel.