DigitalOcean Services Status

Droplet Resize

Incident Report for DigitalOcean

Monitoring

Our Engineering team has identified the root cause of the issue affecting Droplet resizes using the "Downscale Anytime" option and has implemented a fix. Users should now be able to resize their Droplets using the "Downscale Anytime" option without experiencing any issues or errors.

We are actively monitoring the situation to ensure the fix remains effective and will provide another update once the issue has been fully resolved.
Posted Jul 01, 2026 - 12:43 UTC

Investigating

Our Engineering team is investigating an issue affecting Droplet resizes using the "Downscale Anytime" option. At this time users may find this option unavailable or unresponsive in the Cloud Control Panel.

As a workaround, resizes can be performed via the API while we work to resolve this issue.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 01, 2026 - 11:13 UTC
This incident affects: Cloud Control Panel.