DigitalOcean Services Status

App Platform Deployments

Incident Report for DigitalOcean

Resolved

As of 14:54 UTC, our Engineering team confirmed the issue with our App Platform service is fully resolved. Everything should be functioning normally. We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted Jun 16, 2025 - 15:30 UTC

Monitoring

Our engineering team has implemented a fix to resolve the issue impacting our App Platform service and is monitoring the situation closely. We will post an update as soon as the issue is fully resolved.
Posted Jun 16, 2025 - 15:04 UTC

Investigating

Our Engineering team is investigating an issue with our App Platform service. Users find delay in deploying Apps across all regions. At this time, previously deployed running Apps are not impacted. We will provide an update as soon as possible.
Posted Jun 16, 2025 - 14:38 UTC
This incident affected: App Platform (Global).