DigitalOcean Services Status

Cloud Control Panel Logins for a Subset of Users
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue impacting prohibiting a subset of users from logging in, and the login flow is now operating normally.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Dec 11, 2024 - 23:33 UTC
Monitoring
Our Engineering team has implemented a fix for the issue prohibiting a subset of users from logging in. The team is monitoring the situation, and we will share an update once this is fully resolved.
Posted Dec 11, 2024 - 22:53 UTC
Investigating
Our Engineering team is currently investigating an issue prohibiting users from logging in if they are flagged for an additional security challenge.

We are actively reviewing the root cause and working closely to resolve the issue as quickly as possible.

We apologize for the inconvenience and will provide updates as more information becomes available. Thank you for your patience.
Posted Dec 11, 2024 - 19:33 UTC
This incident affected: Cloud Control Panel.