DigitalOcean Services Status

Spaces Availability in FRA1 Region

Incident Report for DigitalOcean

Resolved

Our Engineering team has resolved the performance issue affecting Spaces in the FRA1 region. From approximately 08:02 UTC - 09:40 UTC, customers may have experienced slow performance or limited availability when accessing Spaces, its objects via the Control Panel or API, or Container Registry. All services should now be functioning normally.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Sep 26, 2025 - 10:40 UTC

Monitoring

Our Engineering team has implemented a fix to address the performance issue affecting Spaces in the FRA1 region and is monitoring the situation. Customers should no longer experience slow performance or limited availability when accessing Spaces, its objects via the Control Panel or API, and Container Registry access.

We will post an update as soon as the issue is fully resolved.
Posted Sep 26, 2025 - 10:25 UTC

Investigating

Our Engineering team is investigating a performance issue affecting Spaces in the FRA1 region. During this time, customers may experience slow performance or limited availability when accessing Spaces or its objects via the Control Panel or API, and Container Registry access may also be affected.

We apologize for the inconvenience and will share an update once we have more information.
Posted Sep 26, 2025 - 09:47 UTC
This incident affected: Container Registry (FRA1), Spaces CDN (FRA1), and Spaces (FRA1).